Ecshop模板网
首页 > ecshop教程 > ecshop安装使用 > ECSHOP报错误Deprecated: preg_replace(): The /e modifier is depr
文章详情

ECSHOP报错误Deprecated: preg_replace(): The /e modifier is depr

ecshop模板网 / 2014-07-30

随着PHP5.5 的普及,ECSHOP系统又爆出了新的错误。其实也不能怪人家ECSHOP了,主要是PHP发展的太快了,PHP发展到PHP5.5版本以后,有了很多细微的变化。而ECSHOP官方更新又太慢,发现这些问题后也不及时升级,导致用户安装使用过程中错误百出。说了半天,这个新错误到底是什么呢,它的完整错误提示信息是

这样的:

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in.......
注意:不是所有人的ECSHOP都会报这个错误,只有使用PHP5.5环境的ECSHOP才会报这个错误。
下面我们先来说一下错误产生的原因,然后本站长(QQ:2211707)再告诉你怎么办?

1)、错误原因:
preg_replace() 函数中用到的修饰符 /e 在 PHP5.5.x 中已经被弃用了。
如果你的PHP版本恰好是PHP5.5.X,那你的ECSHOP肯定就会报类似下面这样的错误:
Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in。。。。。。

2)、解决办法:
其实从刚才的错误提示信息中我们也能看出一二,它提示我们使用 preg_replace_callback 来代替 preg_replace。
所以解决方法如下:

使用记事本或其他PHP编辑软件(如:editplus)打开文件 includes/cls_template.php ,找到

return preg_replace("/{([^\}\{\n]*)}/e", "\$this->sel ect('\\1');", $source);

替换为

return preg_replace_callback("/{([^\}\{\n]*)}/", function($r) { return $this->sel ect($r[1]); }, $source);

问题解决。

3)、如果你的ECSHOP中其他文件也报类似的 preg_replace错误,请参照上面方法解决之,解决思路和解决方法是一样的。
下一篇: 为ECSHOP送货地址中的省市区设定一个默认初始值 上一篇: ECSHOP安装或使用中提示Strict Standards: Non-static method cls_image:
 用户评论(共 0 条评论)
  • 暂时还没有任何用户评论
用户名: 匿名用户 E-mail:
当前心情:
评论内容:
验证码: captcha
返回顶部 返回首页
 
QQ在线咨询
售前电话热线
130-5800-8007
售前QQ客服