Ecshop模板网
首页 > ecshop教程 > ecshop安装使用 > ecshop在php高版本中出现错误解决办法
文章详情

ecshop在php高版本中出现错误解决办法

ecshop模板网 / 2014-06-03

重装了本地环境以后,突然发现ecshop出现了好多错误,把错误贴出来一看,主要是以下几个错误,我的php版本是php5.4.28,安装的ecshop版本是ECShop_V2.7.3_UTF8_release1106

下面把错误记录及解决办法记录如下:

Strict Standards: Only variables should be passed by reference in D:\wamp\apache\htdocs\ECCast\includes\cls_template.php on line 418 

解决办法:找到includes/cls_template.php找到第418行,如下

$tag_sel = array_shift(explode(' ',$tag));

将这句拆成两句:$tage_sel1 = explode(' ',$tag);    $tag_sel = array_shift($tage_sel1);
            原因是array_shift()的参数是引用传递,php5.3不知道哪个版本以上,默认只能传递具体变量,不能通过函数的返回值

还一个提示lib_main.php,错误提示和这个是一样的,更改方式也是一样的,需要拆分成两句,原因是引用传递默认传递具体变量,不能通过函数返回值来传递。


Strict Standards: Non-static method cls_image::gd_version() should not be called statically in D:\wamp\apache\htdocs\ECCast\includes\lib_base.php on line 346

    解决办法:找到includes/lib_base.php的346行,会看到

return cls_image::gd_version();

将其改为$gd = new cls_image;    return $gd->gd_version();

看提示能猜到gd_version()不是静态方法,所以不能通过这种方式来调用,::是类的调用方式的,所以会报错的,找到gd_version()这个方法的定义:


function gd_version()

{

include_once(ROOT_PATH . 'includes/cls_image.php');

return cls_image::gd_version();

}

这个时候我们可能会想到两种解决方案,一种是在function前面加上static,因为提示需要一个静态方法才能这样调用,但是会发现这样会提示错误的。。具体原因不太清楚,下去再看把。


另外一种解决办法就是上面所说的了~~

下一篇: 解决ECSHOP在IPAD等平板电脑和智能手机的显示问题 上一篇: 给ecshop系统的商品分类增加外部链接
 用户评论(共 0 条评论)
  • 暂时还没有任何用户评论
用户名: 匿名用户 E-mail:
当前心情:
评论内容:
验证码: captcha
返回顶部 返回首页
 
QQ在线咨询
售前电话热线
130-5800-8007
售前QQ客服